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LaTeXis a powerful free and open-source academic writing system; however, it does come with a learning curve. This curve can be especially steep when trying to incorporate bibliographic references and formatting a document to the current writing style of the field - APA 6th edition. Anyone who has submitted a manuscript for publication is familiar with the trials and tribulations of formatting and citing sources. Any tool to help with this process is a welcome one. Although LaTeX comes close to APA compatibility natively, it doesn’t quite nail it. This post describes how to set-up and integrate a powerful (and free) LaTeX editor with a powerful (and free) citation manager to assist with formatting and citing. To get started, you will need to download and install two programs.


· Texmaker: LaTeX editor
· Zotero: citation manager
Then download two files that will run on these programs.
· APA 6th File: LaTeX document formatting code
· Better BibTex: program for generating cite keys

These programs and files are compatible with the major operating systems. Installation with Windows and macOS is largely a matter of point and click. Installation on Linux requires a bit more know-how of course; and it’s assumed that those using a Linux distribution are familiar with the processes for installing programs and various file extensions. If you are already familiar with the terminology of LaTeX and citation managers then read on. If not, it would be helpful to first review the key terms listed at the end of this post.


[bookmark: zotero-set-up]Zotero Set-up

Zotero can be used separately as a reference manager, but its real utility comes from its ability to generate a bibliographic reference file (i.e., .bib file) that contains cite keys for each of your references. These cite keys are entered into a LaTeX document to generate citations. Although Zotero has a great deal of native functionality, some set-up is required for fluid integration with LaTeX. First, you need to install Better BibTex, a program for generating those cite keys.

From the Zotero toolbar, navigate to: Tools > Add-ons > Extensions.

Select the gear icon in the top-right corner and select ‘Install Add-on From File…’ Navigate to the folder where you saved the Better Bibtex file and install it. At this point you will need to restart Zotero to complete the install and auto-update to the most recent version of Better Bibtex. Navigate back to Extensions and make sure Better Bibtex is now listed. You may see an option for preferences. Don’t worry about setting-up the Better BibTex preferences yet; that will be done in a moment.
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Next, set your general Zotero preferences. Close the Add-ons Manager. You should now be back to the main Zotero screen. From the toolbar, navigate to: Edit > Preferences.

Navigate to the ‘Export’ icon, scroll through the drop down and select ‘Better BibTex’.
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Next, navigate to the ‘Better BibTex’ icon in the toolbar. Navigate to the ‘Citation keys’ tab, open the ‘QuickCopy/drag-and-drop citation area’ and select Cite Keys’. This commands Zotero to populate the bibliography file with cite keys that can be included in the LaTeX document. You can change the ‘Citation key format’ if desired, but the default ‘[auth][shorttitle][year]’ should work just fine under normal use cases.
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Navigate to the Export tab. Under BibLaTeX, make sure ‘Export unicode as plain-text latex commands’ is checked. Open the ‘Add URLs to BibTeX export’ drop down and select ‘in a note filed’. Some APA citation types require a URL so you want your bibliographic file to include them. Open the ‘When a reference has both a DOI and a URL, export’ drop down and select ‘DOI’. This will ensure that your LaTeX references does not simultaneously include a URL and DOI.
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It’s common during writing to make changes to your reference list; and Zotero can update your exported bibliographic files even after they have been generated. Navigate to the Automatic export tab. Open the ‘Automatic export’ drop down and select ‘On Change’. This commands Zotero to update the exported bibliographic file as soon as you make any changes in the parent reference library in Zotero. This option works just fine in most cases; however, if you tend to do a lot of heavy processing with your computer or are working with old hardware, you may want to select ‘When idle’.
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At this point, Zotero should be ready to generate a bibliographic file (e.g., .bib file) for use with your LaTeX document. To do this, go back to the main Zotero page and navigate to File > Export Library. Make sure Format is set to ‘Better BibLaTeX’ and select the option to ‘Keep updated’. This will ensure that any changes you make to your parent Zotero library will be pushed out to the exported .bib file.
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Save the .bib file anywhere for now. You will want to move it into the LaTeX folder that you will create later. If you are curious about the contents of the .bib file, you can open it with any code editor such as Atom or Sublime Text. Plain text editors will work to an extent, but the formatting can be rather wonky with these.


[bookmark: texmaker-set-up]Texmaker Set-up

Texmaker is the LaTeX editor. It comes with enough point and click supports to help the novice user, and enough functionality to satisfy the advanced user. If you are working on Windows or macOS, you may be prompted to install certain functionality during set-up or initial use. If you are installing on Linux OS, you should first install the TeX Live dependency. For Debian based distributions, that can be done with the following command.



sudo apt install texlive-full
You will need to configure Texmaker to work with Better BibTeX. First, command Texmaker to use a function called biber that interprets the Better BibTex generated cite keys.

From the Texmaker toolbar, navigate to: Options > Configure > Commands.

In the Bib(la)tex window replace the default command (probably ‘bibtex %.aux’) with ‘biber %’. This commands Zotero to use the correct citation formatting when compiling a document. Be sure to remove the quotation marks around the command. Note that the command is all lower case and there is a space between the word and the percent symbol.
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Now command Texmaker to incorporate citations when compiling the document. You should already be in Options > Configure, so just navigate to Quick Build. Change radio button from the default (probably ‘PdfLaTeX+View PDF’) to ‘PdfLaTex+Bib(la)tex+PdfLaTeX(x2)+View Pdf’. This will command Texmaker to integrate the bibliographic reference file when compiling.
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It is also a good idea to have Texmaker regularly back-up your writing. You should still be in Options > Configure, so just navigate to Editor and ensure that ‘Backup documents every 10 min’ is selected. This is not a necessary function, but it is recommended.
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[bookmark: writing-with-the-apa-6th-file]Writing with the APA 6th File

Now that Zotero and Texmaker are ready, you just need a LaTeX template preloaded with the necessary formatting code. You could do this yourself, but it can be rather tricky to get everything just right. This is where the APA 6th file that you downloaded from the Comprehensive TEX Archive Network (CTAN) comes in. Brian Beitzel has done the heavy lifting by developing a Texmaker compatible file that already includes the required APA 6th formatting code. The file is released under the GNU General Public License which allows for public distribution and use. Brian has even provided an extensive overview of functionality if you want to dig a bit deeper into the code, and a crosswalk with APA 6th alignment.
Simply open the file in Texmaker (Ctrl+O). You will notice a lot of formatting code within the preamble. One important thing you will see is a prodigious use of the ‘%’ sign. The ‘%’ sign indicates that the content that follows is a comment and should not be included when compiling. This content will be grayed-out. To make this content active, and included in the compile, simply remove the ‘%’ sign. Now try entering some basic information into the preamble; then save the document.
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LaTeX generates multiple files for a single document, so you may want to create a folder for each document you make. Now that you have a folder for your document, consider moving the bibliographic reference file (e.g., .bib file) you created into it. This is not necessary, but it’s good practice to have everything used for the writing process in one place. Once you’ve saved the document, you will be able to compile it. The keyboard shortcut for compiling in Texmaker is ‘F1’. When you compile, a nicely formatted pdf should appear beside your LaTeX code. If you do not see the pdf, make sure the Pdf Viewer is toggled on.
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For LaTeX to incorporate citations, it needs to know where to find them. In the preamble of the document you will find this.


% Add your BibTeX files here. Use source location if you aren't keeping them in the same folder as your document.

\addbibresources{yourbib.bib}
Within the curly brackets (i.e., ‘{}’), insert the pathway to the reference .bib file. Even if the .bib file is located in the same folder as the LaTeX .txt file, it’s still good practice to enter the location. Once this location is specified, you will be able to add citations in the text as you write without having to go back to Zotero. The standard code for adding a citation with LaTeX is: (missing citation), where the period is replaced with the desired cite key. However for compatibility with the bibercitation formatting, adding a citation is done with: \parencite{.}, where the period is replaced with the desired cite key. Of course, citations sometimes need the author suppressed or accompanying notes. LaTeX can also accommodate these as well.


\parencite*{.} Suppresses author name and print year in parentheses

\parencite[e.g.,][p10]{.} Add a page number to the citation and e.g., as a prenote

\parencite[e.g.,][]{.} Add e.g., as a prenote and suppress any postnote

With the citation code added, you need to insert the desired reference from your .bib file. There are a variety of ways to do this. The most straightforward way is to use a drop down list that appears once you begin adding the citation code; unfortunately a drop down does not appear when you type \parencite{}. This seems to be a quirk of the biber citation format that afflicts some systems. Fortunately there is a simple work-around if this happens to you. Begin with the standard \cite{} code. This is recognized by editor and a drop down list of all the references in the .bib file should appear. Add the desired reference(s), then go back and change \cite to \parencite while retaining the citation.

Now that you have added references to your document, a complete reference section will be created each time you compile. No more having to go back through each of your citations and manually create a reference list. Your references will appear in alphabetical order by the first author’s last name, and redundant citations will be listed only once. References will be added or removed from your document each time you compile based on the changes you make as you write. Keep in mind that the extent to which your references comply with APA 6th is contingent upon their proper entry into Zotero. If you have entered information incorrectly (e.g., capitalized all words in the title of a journal article) your reference will still print with these errors.


[bookmark: why-so-many-files]Why So Many Files?

Like all LaTeX editors, Texmaker will produce multiple files when compiling a document so it’s useful to create a unique folder (i.e., directory) for each document you plan to create. Among these files, you will typically just be concerned with two: the .txt file and the .pdf file.
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The .txt file is the LaTeX file itself. This is the one you want to select to open a file in Texmaker. The .pdf is your final document that is generated and updated every time you compile the LaTeX code. It’s good practice to compile often as you write. If there are errors that inhibit compiling, you will have fewer things to debug if you compile frequently. You did set the editor to back-up every 10 minutes, but backing up does not compile the document, it simply saves your changes. You also notice in the above screenshot the ‘test-library.bib’ file is located in the same folder as the .txt file. This is the bibliographic file created from Zotero. Although the file need not necessarily be stored in the document folder, it is good practice to do so.


[bookmark: closing-thoughts]Closing Thoughts

The LaTeX learning curve is worth the effort if you’re involved in academic writing. It gets you out of proprietary word processors and allows for a wide range of customization. Because it’s open source, you can find a community-developed application or code for just about anything you need do to within a document. For support, there is also an enthusiastic community of users who willingly share their knowledge.
The process described in this post is just one way of writing APA 6th compliant academic articles with LaTeX. Other options and variations on this process exist. Hopefully, this post will get the novice started in the right direction and even help experienced users troubleshoot ongoing issues.
If you are completely new to writing with LaTeX, there are a number of great tutorials to get you started. Michelle Krummel’s YouTube channel is accessible and informative, as is the LaTeX Wikibooks page. Getting all these components to work together properly will take time and you may find that some variations on the process described here are needed. Results may vary depending on the type of OS and version you are running. Be patient, expect some challenges, and enjoy writing.


[bookmark: key-terms]Key Terms:


· LaTeX: Free and open source system (coding language) used for academic writing and typesetting. In LaTeX, the formatting of your document is created separately from the content of your document. Formatting is written in LaTeX code and content is written as you would in a word processor.
· LaTeX Editor: A program that runs LaTeX (e.g., Texmaker).
· Compile: Generating a PDF document from LaTeX formatting code and content. This is the process of combining formatting and content into a finished document, and is an integrated function of the LaTeX editor. The keyboard shortcut for this in Texmaker is ‘F1’.
· Preamble: Formatting code at the beginning of a LaTeX document that specifies the purpose, structure, and formatting of the document.
· Citation Manager: An application that organizes references and generates citations for inclusion in documents. (e.g., Zotero)
· Cite Keys: Information about given references generated by the citation manager and placed in the document by the author that allow the BibTeX file to insert references into the text and automatically create a reference list.
· BibLaTex: A file type that contains cite keys and metadata about the included references. This is also know as a .bib file. An earlier and somewhat outdated version of this file type is BibTex.
· Better BibTex: An enhanced form of a BibTex/BibLaTeX file.
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#\usepackage [12tabu] {nag}

% title, etc

\title{Academic Writing With LaTeX}
\shorttitle{Shortitle}
\author{Charles C. Igel}

% The following four fields make up some of the front matter of your document. If working on an assignment for a course, I
typically use "affiliation" for the class mame. I have commented out abstract since minimal usage doesn't require it and
leaving it blank will generate a blank page. Ignore the warning about the lack of abstract

\affiliation{Regis University}

\abstract{LaTeX is a powerful free and open-source academic writing system; however, it does come with a learning curve. This
curve can be especially steep when trying to incorporate bibliographic references and formatting a document to the current
Standards of the field - APA 6th edition. Anyome who has submitted a manuscript for publication is familiar with the trials
and tribulations of formatting and citing sources. Any tool to help with this process is a welcome one. Although LaTeX comes
close to APA compatibility natively, it doesn't quite mail it. This post describes how to set-up and integrate a common (and
free) LaTeX editor with a common (and free) citation manager to assist with formatting and citing.r

\keywords{LaTeX, Academic Writing, APA 6th, TexMaker}

\authornote{}

\begin{document}
\maketitle
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